
Switch 2.0 Tutorial: Pre-Tutorial Setup 
 

Before you begin the tutorial, please complete the steps described here to install Switch on 
your computer and learn some background information. You will need an Internet 
connection while you do these. Required steps are marked by a blue bar in the margin like 
this paragraph. Explanatory text and optional steps don’t have this mark. 

 
These instructions are simplified to minimize the number of elements you have to download 
and install. They use data and solver programs that you will find in an accompanying zip file, 
and they use a simplified method to install Switch. For a more common (but slower) way to 
install Switch, see the tutorial at https://switch-model.org. 

1 Software setup (approx. 1 hour; requires 4-5 GB disk space) 

This section describes how to install Switch on your computer so it is ready to solve power 
system planning problems. Switch depends on a collection of mostly open-source software:  
 

• Visual Studio Code (VS Code) is an open-source editor and terminal program which is 
useful for editing input files and typing commands to run Switch. (You can use a 
different programming-oriented editor if you prefer.) 

• Anaconda provides an easy, standardized way to install Switch and the software that it 
depends on (described below). 

• Switch is a program that can be used to define and solve a power system optimization 
model using inputs that you provide. It is made up of a collection of modules written in 
the Python language, each of which describes a different aspect of the power system. 

• Pyomo is a general-purpose optimization modeling framework for Python. Switch uses 
Pyomo to define the elements of your optimization model and call a solver.  

• Pyomo converts the Switch model into a standardized, computer-readable form and 
sends it to an external solver (e.g., glpk, cbc, cplex or gurobi). The external solver does 
the intense computation required to find an optimal plan. 

 
The instructions below will show you how to setup all of the components described above. All 
of these tools are open-source and cross-platform, so you should be able to use them on any 
computer.  
 
Disk usage: Switch itself is quite small, but it depends on the Anaconda distribution (0.3-0.5 
GB), and a number of Python packages (0.5-1.5 GB). We will also use the Visual Studio Code 
text editor for this tutorial (0.3 GB), and install some tutorial data (0.3 GB). Note that the higher 
disk usage numbers are for Windows installations. 
 

1.1 Installing Anaconda and Python 

Download and install the Miniforge3 version of Anaconda from https://github.com/conda-
forge/miniforge?tab=readme-ov-file. (If that link doesn’t work, you can also try miniconda3 

https://switch-model.org/
https://github.com/conda-forge/miniforge?tab=readme-ov-file
https://github.com/conda-forge/miniforge?tab=readme-ov-file
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from https://docs.anaconda.com/free/miniconda/; they should both work equally well.) We 
recommend selecting the latest 64-bit version for your platform and processor (other 
versions will probably work too). On a Mac, the “.pkg” installer is easier to use than the 
“bash” one. When installing, you can use the recommended options (install just for me, 
create start menu shortcut, don’t add to PATH environment variable). 

 
If you like, you can complete the Anaconda tutorial offered at the end of the installer, but it is 
not needed for this tutorial. 
 
If you already use a different version of Anaconda, miniconda or Miniforge, that should work 
fine for this tutorial. 
 

1.2 Installing Visual Studio Code text editor 

For this tutorial, we assume you are using the Visual Studio Code (VS Code) text editor to view 
and edit code and data files. You can use a different text editor if you like, but it should be 
capable of doing programming-oriented tasks, like quickly adjusting the indentation of many 
lines in a text file. If you prefer, you can also open the .csv data files directly in your spreadsheet 
software instead of using VS Code. 
 

Download and install the Visual Studio Code text editor from https://code.visualstudio.com/. 
(On Windows, you can also find Visual Studio Code in the Microsoft Store.) 

 
If you need more information on installing VS Code, see 
https://code.visualstudio.com/docs/setup/setup-overview. (On a Mac you may need to double-
click on the downloaded zip file to uncompress it, then use the Finder to move the “Visual 
Studio Code” app from your download folder to your Applications folder.) 
 
If you'd like a quick introduction to VS Code, see https://code.visualstudio.com/docs (not 
needed for this tutorial). 
 

Launch Visual Studio Code from the Start menu (Windows) or Applications folder (Mac). You 
can choose a color theme and/or work your way through the “Get Started” steps (it’s a 
scrollable list), or you can skip them if you don’t want to do that now.  

 
Follow these steps to install the Python extension for VS Code: 
 
- Click on the Extensions icon on the Activity Bar on the left side of the Visual Studio Code 

window (or choose View > Extensions from the menu). The icon looks like four squares: 

 
- This will open the Extensions pane on the left side of the window. Type “Python” in the 

search box, then click on “Install” next to the Python extension that lists Microsoft as the 

https://docs.anaconda.com/free/miniconda/
https://code.visualstudio.com/
https://code.visualstudio.com/docs/setup/setup-overview
https://code.visualstudio.com/docs


Switch 2.0 Tutorial: Pre-Tutorial Setup  April 25, 2024 

 3 

developer: 

 
- After installing the Python extension, you will see a “Get started with Python 

development” tab and a “Get started with Jupyter Notebooks” tab. You can close these. 
 

Follow these steps to install two more extensions that will be useful for this tutorial. These 
are optional, but they make it easier to read and edit data stored in text files, such as the .csv 
files used by Switch: 
 
- Type “rainbow csv” in the search box in the Extensions pane, then click on “Install” next 

to the Rainbow CSV extension (this is optional, but makes it easier to read and edit data 
stored in text files, such as the .csv files used by Switch): 

 
- Type “excel viewer” in the search box, then click to install the Excel Viewer extension (this 

is also optional, but gives a nice grid view of .csv files): 

 
 

If you are running on Windows, choose File > Preferences > Settings, then search for “default 
profile” and choose “Integrated > Default Profile: Windows”. Then change the setting to 
“Command Prompt” instead of “null” or “PowerShell”. Then close the Settings tab. (In some 
Windows configurations, PowerShell doesn’t run correctly inside VS Code or doesn’t find the 
conda environment, and it also has a built-in “switch” command that may hide the “switch” 
command used to run Switch. So we use the “Command Prompt” profile instead.) 

 
If you are running on macOS, choose Code > Preferences > Settings, then search for 
“terminal inherit” and uncheck the box next to “Terminal › Integrated: Inherit Env”. This can 
be helpful for making sure terminal panes in VS Code work correctly. 

 
We also recommend that you open File > Preferences > Settings (Windows) or Code > 
Preferences > Settings (Mac), then search for “open folder” and set the option to “on” for 
“Window: Open Folders in New Window.” 

 
Now you can close VS Code or leave it open. You can click again on the Extensions icon to make 
the Extensions pane disappear; we won’t need it again in this tutorial. 
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1.3 Download tutorial data and Switch source code 

Next, download the Switch_Tutorial_Small.zip and Switch_Tutorial_battery_study.zip files 
from https://switch-model.org/china_tutorial/index.html and decompress them into a 
convenient location, such as your home directory. These folders contain the data and 
configuration files we will use for the tutorial and a copy of the Switch source code that you 
can review as needed. 
 
Next, in Visual Studio Code, choose File > Open Folder and choose Switch_Tutorial_Small. If 
you are asked whether you trust the authors of the files in the folder, choose “yes”.  

 

1.4 Installing Switch and Pyomo 

In Visual Studio Code, choose View > Command Palette… from the menubar, then search for 
the option “Python: Select Interpreter”. Wait a little while for the full list of interpreters to 
appear. Click on the one that mentions “(‘base’)” and has “miniforge3” or “condaforge3” in 
the path name. The display won’t update much, but VS Code is now configured to use the 
copy of Python you installed earlier whenever you open the tutorial folder.  
 
Next choose Terminal > New Terminal from the menu bar. This will open a pane at the 
bottom of the VS Code window where you can type commands to the operating system.  
 
You should see a command line with “(base)” in the prompt. If you don’t see these, you may 
need to repeat the “Select Interpreter” command above and then open a new terminal pane, 
or you may need to use a different terminal (see end of this section). 
 
Next choose Terminal > New Terminal and run the following command at the command line. 
This will install Switch and all its dependencies into your “base” environment in conda. 

 
pip install switch_model==2.0.8 

 
The next command is optional but if you use it, Switch will automatically produce some graphs 
when it solves; these packages are also useful for making your own graphs of results. 
 

pip install plotnine matplotlib 

 
You can check that Switch has been installed by running the commands below at the 
command prompt: 

 
switch --version 

pyomo --version 

 
You should see version numbers for each one and no errors. 
 

https://switch-model.org/china_tutorial/index.html
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If your computer reports that these commands are not found, try choosing View > Command 
Palette again, then Python: Select Interpreter and choose the “base” environment again. Then 
choose Terminal > New Terminal and try the commands above again. If this still doesn’t work, 
you can try opening Terminal.app (on a Mac) or Miniforge Prompt, Anaconda Prompt or Conda 
Prompt (on Windows) instead of VS Code, and then running the commands there. If that works, 
you can then run all the commands listed in square boxes in this tutorial in Terminal.app or the 
Miniforge Prompt instead of in the VS Code terminal pane.  
 
Note: you now have two copies of Switch on your system—one for running (inside the conda 
base environment), and one for viewing (inside your tutorial directory). Any changes you make 
to the copy inside your tutorial directory will not affect the copy you use to solve models.  
 

1.5 Installing Solvers 

Download the Solvers*.zip file for your operating system from https://switch-
model.org/china_tutorial/index.html. This contains copies of the open-source GLPK and HiGHS 
open-source solvers. Decompress this folder, then copy the two files from inside to a place 
where your computer can find them (somewhere in the program search path). One good place 
to put them is in the scripts folder in your base conda environment. You can find this location 
by typing “where switch” in the Visual Studio Code terminal pane. This will tell you where the 
“switch” command is installed. Navigate to that location in Windows Explorer or the Finder 
(macOS), then copy the glpsol and highs files there. Once you have done this, you can test that 
your computer is able to find them by running these commands:  
 

glpsol --version 

highs -v 

 
If you are using macOS or Linux, you may need to run “chmod +x ~/miniforge3/bin/highs” and 
“chmod +x ~/miniforge3/bin/glpsol” (or similar) to make the solvers executable. 
 
Note that this is an unusual way to install these solvers. Often it is easier to install them with a 
command like “conda install glpsol”. (For highs, it is more complicated; you need to run “conda 
install highs” then “pip install highspy”, then specify “--solver appsi_highs” when running 
Switch; this will only work with switch 2.0.8 or later, which was released in late April 2024.) 
 
The GLPK and HiGHS solvers are able to solve small test cases, but they are not fast enough to 
solve large models. You can complete this tutorial using only GLPK; HiGHS is often several times 
faster. Another option is CBC, which has similar performance to HiGHS (on Mac and Linux you 
can install CBC by running “conda install -c conda-forge coincbc”, then specifying “--solver cbc” 
when running Switch. CBC is currently difficult to install on Windows). 
 
However, if you would like to solve larger models, such as the battery_reserves example or the 
full Switch-China model, you will need to install a faster solver such as CPLEX, Gurobi or possibly 
Cardinal Optimizer. These are about 5 to 100 times faster than HiGHS or Gurobi. These are 

https://switch-model.org/china_tutorial/index.html
https://switch-model.org/china_tutorial/index.html
https://github.com/switch-model/switch-china-open-model/
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expensive for professional use, but it is possible to get a trial license before you buy a long-term 
one. Academics can also get full licenses for free. Note that it is important to get a license 
(temporary or long-term) for the full version of the software with not size limits. These 
companies also offer free or community versions, but those only allow small problem sizes. 
 
Gurobi is quite easy to install – you just need to run “pip install gurobi” or “conda install -c 
gurobi gurobi”, then put a license file in your home directory. CPLEX is quite complex to find 
and install, but has simpler licensing (for academics). If using Cardinal Optimizer, you should 
download the version that is made to run with AMPL, and then install it similarly to how you 
installed HiGHS and GLPK above. 
 
Once you have installed one of these, you can select it when you run Switch by specifying --
solver cplex, --solver gurobi or –copt on the switch command line or in options.txt (discussed in 
the main tutorial). 

2 Introduction to Switch, Pyomo and Python (0.5 – 9 hours) 

This section points you to some useful, quick introductions to Switch, Python and Pyomo. The 
latter two are optional, but recommended if you will be using Switch extensively or defining 
custom behaviors (new technologies, rules or policies). 
 

2.1 Introduction to Switch (0.5 – 2 hours) 

For a quick overview of Switch, please read Section 2 of the paper on Switch 2.0 at 
https://doi.org/10.1016/j.softx.2019.100251.  

 
The following are optional: You can read section 3 of the Switch paper (above) for an overview 
of the case study we’ll examine during this tutorial. And if you would like more detail on Switch, 
please see the Supplementary Material for the Switch 2.0 paper at  
https://ars.els-cdn.com/content/image/1-s2.0-S2352711018301547-mmc1.pdf. 
 

2.2 Introduction to Python (optional, 1 – 6 hours) 

We recommend reading sections 3 and 4 of the Python introduction at 
https://docs.python.org/3/tutorial/ . If you would like a deeper understanding, sections 5 and 6 
are also worth reading. 
 
If you want to run sample code from the Python tutorial, you can do so as follows:  
 

• Open VS Code.  

• Choose File > Open Folder… to select a folder where you’d like to work (can be an empty 
scratch folder or the folder where you downloaded the switch data earlier).  

• Choose Terminal > New Terminal.  

• Type “python<enter>” in the terminal pane to start the Python interpreter.  

https://doi.org/10.1016/j.softx.2019.100251
https://ars.els-cdn.com/content/image/1-s2.0-S2352711018301547-mmc1.pdf
https://docs.python.org/3/tutorial/
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• Type code from the Python tutorial into the interpreter as needed. Generally the code 
marked with “>>>” or “...” is code that you can type to the Python interpreter. But you 
should not copy the >>> or ... symbols themselves. 

 

2.3 Introduction to Optimization and Pyomo (optional, 1 – 3 hours) 

We recommend going through the following sections at https://pyomo.readthedocs.io/ to get 
an introduction to Pyomo, the optimization software used by Switch. 

• Pyomo Overview 

• Pyomo Modeling Components 
 
This will enable you to read and write Switch code, which is just Pyomo code applied to power 
system modeling. i.e., a Switch model is a Pyomo AbstractModel used to optimize the design of 
a power system. 

Notation: In the Pyomo introduction, you will see problems with a notation like this: 

min c1x1 + c2x2 
s.t. 
a11 x1 + a12 x2 ≥ b1 
a21 x1 + a22 x2 ≥ b2 
x1 ≥ 0 
x2 ≥ 0 

This is a common way to describe mathematical optimization problems. It means "find values 
for x1 and x2 that will minimize the value of c1x1 + c2x2, such that all the specified constraints are 
satisfied." 

In this problem, the x values are called decision variables (these are numbers that will be 
chosen when the problem is run, e.g., the amount of power to produce from a project during a 
particular hour), the a, b, and c values are parameters (data you know when you set up the 
problem, e.g., the maintenance cost per MWh produced from a project), c1x1 + c2x2 is the 
objective function (the value to be minimized or maximized), and the other equations are the 
constraints (e.g., that power output is less than or equal to installed capacity).  

Now you are ready for the Switch tutorial. 
 

https://pyomo.readthedocs.io/
https://pyomo.readthedocs.io/en/stable/pyomo_overview/index.html
https://pyomo.readthedocs.io/en/stable/pyomo_modeling_components/index.html
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